// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<br />(.+?)ar />").unwrap();
let string = "SMPN 2 Aesesa Selatan<br />SMPN 2 Aesesa Selatan<br />Desa/Kel. Lange Dhawe<br />Kec. Aesesa Selatan<br />Kab. Nagekeo<ar />Nusa Tenggara Timur<br />Type : USB<br />Progress : COMPLETED";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}