# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(['"`])(?:(?<!\\)\\(?:\\\\)*\1|(?!\1).)*\1(*SKIP)(*F)|\\n//g;t' <<< "\nnew\"test\naaaa\"\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n
\n`escaped quote:\` this should be kept: \n `\n
\n`not a escaped quote:\\` this should not be kept: \n `\n
\n`escaped quote:\\\` this should be kept: \n `\n"