$re = '/([\'"`])(?:(?<!\\\\)\\\\(?:\\\\\\\\)*\1|(?!\1).)*\1(*SKIP)(*F)|\\\\n/';
$str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`\\ntest\\n\'this \\n should also be kept\'\\n
\\n`escaped quote:\\` this should be kept: \\n `\\n
\\n`not a escaped quote:\\\\` this should not be kept: \\n `\\n
\\n`escaped quote:\\\\\\` this should be kept: \\n `\\n';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;