const regex = /(['"`])(?:(?<!\\)\\(?:\\\\)*\1|(?!\1).)*\1(*SKIP)(*F)|\\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'"`])(?:(?<!\\\\)\\\\(?:\\\\\\\\)*\\1|(?!\\1).)*\\1(*SKIP)(*F)|\\\\n', 'g')
const str = `\\nnew"test\\naaaa"\\nta\\n\`this is a \\nnewline that should be kept\`\\ntest\\n'this \\n should also be kept'\\n
\\n\`escaped quote:\\\` this should be kept: \\n \`\\n
\\n\`not a escaped quote:\\\\\` this should not be kept: \\n \`\\n
\\n\`escaped quote:\\\\\\\` this should be kept: \\n \`\\n`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);