using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""`])(?:(?<!\\)\\(?:\\\\)*\1|(?!\1).)*\1(*SKIP)(*F)|\\n";
string substitution = @"";
string input = @"\nnew""test\naaaa""\nta\n`this is a \nnewline that should be kept`\ntest\n'this \n should also be kept'\n
\n`escaped quote:\` this should be kept: \n `\n
\n`not a escaped quote:\\` this should not be kept: \n `\n
\n`escaped quote:\\\` this should be kept: \n `\n";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}