using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!Doe, John)[^\r\n]+:$\R(.*?(?=\R[^\r\n[]+\[.*:|\Z))";
string input = @"Smith, Joe [10:48AM]:
Hey guys!
How's it going?
Smith, Jane [10:49AM]:
Hey!
Doe, John [10:50AM]:
Wassup!
Where are we going out today?
Smith, Joe [10:48AM]:
Hey guys!
How's it going?
Smith, Jane [10:49AM]:
Hey!
Doe, John [10:50AM]:
Wassup!
Where are we going out today?
Smith, Joe [10:48AM]:
Hey guys!
How's it going?
Smith, Jane [10:49AM]:
Hey!";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}