import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!Doe, John)[^\\r\\n]+:$\\R(.*?(?=\\R[^\\r\\n[]+\\[.*:|\\Z))";
final String string = "Smith, Joe [10:48AM]:\n"
+ "Hey guys!\n"
+ "How's it going?\n"
+ "Smith, Jane [10:49AM]:\n"
+ "Hey!\n"
+ "Doe, John [10:50AM]:\n"
+ "Wassup!\n"
+ "Where are we going out today?\n"
+ "Smith, Joe [10:48AM]:\n"
+ "Hey guys!\n"
+ "How's it going?\n"
+ "Smith, Jane [10:49AM]:\n"
+ "Hey!\n"
+ "Doe, John [10:50AM]:\n"
+ "Wassup!\n"
+ "Where are we going out today?\n"
+ "Smith, Joe [10:48AM]:\n"
+ "Hey guys!\n"
+ "How's it going?\n"
+ "Smith, Jane [10:49AM]:\n"
+ "Hey!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}