import re
regex = re.compile(r"^(?!Doe, John)[^\r\n]+:$\R(.*?(?=\R[^\r\n[]+\[.*:|\Z))", flags=re.DOTALL | re.MULTILINE)
test_str = ("Smith, Joe [10:48AM]:\n"
"Hey guys!\n"
"How's it going?\n"
"Smith, Jane [10:49AM]:\n"
"Hey!\n"
"Doe, John [10:50AM]:\n"
"Wassup!\n"
"Where are we going out today?\n"
"Smith, Joe [10:48AM]:\n"
"Hey guys!\n"
"How's it going?\n"
"Smith, Jane [10:49AM]:\n"
"Hey!\n"
"Doe, John [10:50AM]:\n"
"Wassup!\n"
"Where are we going out today?\n"
"Smith, Joe [10:48AM]:\n"
"Hey guys!\n"
"How's it going?\n"
"Smith, Jane [10:49AM]:\n"
"Hey!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")