$re = '/^(?!Doe, John)[^\r\n]+:$\R(.*?(?=\R[^\r\n[]+\[.*:|\Z))/sm';
$str = 'Smith, Joe [10:48AM]:
Hey guys!
How\'s it going?
Smith, Jane [10:49AM]:
Hey!
Doe, John [10:50AM]:
Wassup!
Where are we going out today?
Smith, Joe [10:48AM]:
Hey guys!
How\'s it going?
Smith, Jane [10:49AM]:
Hey!
Doe, John [10:50AM]:
Wassup!
Where are we going out today?
Smith, Joe [10:48AM]:
Hey guys!
How\'s it going?
Smith, Jane [10:49AM]:
Hey!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);