package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`20[0-9]{2}[01][0-9][0123][0-9]`)
var str = `20160339
20130123
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}