$re = '/20[0-9]{2}[01][0-9][0123][0-9]/';
$str = '20160339
20130123
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);