const regex = /20[0-9]{2}[01][0-9][0123][0-9]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('20[0-9]{2}[01][0-9][0123][0-9]', '')
const str = `20160339
20130123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}