using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(word1).*(word2)";
string input = @"This is a test. her is word1 and here is where word2 may or may not be.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}