const regex = /(word1).*(word2)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(word1).*(word2)', 'gi')
const str = `This is a test. her is word1 and here is where word2 may or may not be.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}