re = /(word1).*(word2)/i
str = 'This is a test. her is word1 and here is where word2 may or may not be.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end