$re = '/(word1).*(word2)/i';
$str = 'This is a test. her is word1 and here is where word2 may or may not be.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);