#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^..(.)..(.).(.).*$"
Local $sString = "123456789"
Local $sSubst = "\1 \2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)