$re = '/^..(.)..(.).(.).*$/';
$str = '123456789';
$subst = "\1 \2 \3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;