use strict;
my $str = '123456789';
my $regex = qr/^..(.)..(.).(.).*$/p;
my $subst = '\\1 \\2 \\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";