import re
regex = re.compile(r"^..(.)..(.).(.).*$")
test_str = "123456789"
subst = "\\1 \\2 \\3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)