#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:(?!(\w)(\w)\2?\1)\w)+\b"
Local $sString = "" & @CRLF & _
"xbarrabzz/1xoxxoxa14" & @CRLF & _
"" & @CRLF & _
"hello, world, sun, x, mine, hola " & @CRLF & _
"ohho, izzil, 112maam, 01221555" & @CRLF & _
"" & @CRLF & _
"xyx" & @CRLF & _
"racecar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")