const regex = /\b(?:(?!(\w)(\w)\2?\1)\w)+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?!(\\w)(\\w)\\2?\\1)\\w)+\\b', 'g')
const str = `
xbarrabzz/1xoxxoxa14
hello, world, sun, x, mine, hola
ohho, izzil, 112maam, 01221555
xyx
racecar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}