re = /\b(?:(?!(\w)(\w)\2?\1)\w)+\b/
str = '
xbarrabzz/1xoxxoxa14
hello, world, sun, x, mine, hola
ohho, izzil, 112maam, 01221555
xyx
racecar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end