using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?!(\w)(\w)\2?\1)\w)+\b";
string input = @"
xbarrabzz/1xoxxoxa14
hello, world, sun, x, mine, hola
ohho, izzil, 112maam, 01221555
xyx
racecar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}