using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\+]?(\(?[0-9]{3}\)?)?[\s]?[\+\-]?[\s]?[0-9]{4}[\-\s]?[0-9]{4}";
string input = @"502 2332 3223";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}