$re = '/[\+]?(\(?[0-9]{3}\)?)?[\s]?[\+\-]?[\s]?[0-9]{4}[\-\s]?[0-9]{4}/';
$str = '502 2332 3223';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);