re = /[\+]?(\(?[0-9]{3}\)?)?[\s]?[\+\-]?[\s]?[0-9]{4}[\-\s]?[0-9]{4}/
str = '502 2332 3223'
# Print the match result
str.match(re) do |match|
puts match.to_s
end