package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\+]?(\(?[0-9]{3}\)?)?[\s]?[\+\-]?[\s]?[0-9]{4}[\-\s]?[0-9]{4}`)
var str = `502 2332 3223`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}