import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[(?P<string1>.*?)\\])\\s*(?P<string2>[^\\(]*)\\s*(\\((?P<string3>.*)\\))?";
final String string = "[string1...] string2 in english/chinese (string3...)?\n"
+ "[string1...] string2 in english/chinese \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}