$re = '/(\[(?P<string1>.*?)\])\s*(?P<string2>[^\(]*)\s*(\((?P<string3>.*)\))?/';
$str = '[string1...] string2 in english/chinese (string3...)?
[string1...] string2 in english/chinese
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);