const regex = /(\[(?P<string1>.*?)\])\s*(?P<string2>[^\(]*)\s*(\((?P<string3>.*)\))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[(?P<string1>.*?)\\])\\s*(?P<string2>[^\\(]*)\\s*(\\((?P<string3>.*)\\))?', 'g')
const str = `[string1...] string2 in english/chinese (string3...)?
[string1...] string2 in english/chinese
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}