#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\()\$[\d\.]+(?!.*?\))"
Local $sString = " Current charges (inc. GST $12.23 -see over for details) $134.55" & @CRLF & _
" Total amount due (inc. GST $7.68) $84.55" & @CRLF & _
"3% discount on usage if you pay this bill by the due date $2.79Cr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")