$re = '/(?<!\()\$[\d\.]+(?!.*?\))/';
$str = ' Current charges (inc. GST $12.23 -see over for details) $134.55
Total amount due (inc. GST $7.68) $84.55
3% discount on usage if you pay this bill by the due date $2.79Cr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);