import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\()\\$[\\d\\.]+(?!.*?\\))";
final String string = " Current charges (inc. GST $12.23 -see over for details) $134.55\n"
+ " Total amount due (inc. GST $7.68) $84.55\n"
+ "3% discount on usage if you pay this bill by the due date $2.79Cr";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}