use strict;
my $str = ' Current charges (inc. GST $12.23 -see over for details) $134.55
Total amount due (inc. GST $7.68) $84.55
3% discount on usage if you pay this bill by the due date $2.79Cr';
my $regex = qr/(?<!\()\$[\d\.]+(?!.*?\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}