using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(((?:[^()]+|\((?1)\))+)\)";
string input = @"test (with (nested and (more nested)) parenthesis) till the end with (additional parens)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}