$re = '/\(((?:[^()]+|\((?1)\))+)\)/';
$str = 'test (with (nested and (more nested)) parenthesis) till the end with (additional parens)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);