re = /\(((?:[^()]+|\((?1)\))+)\)/
str = 'test (with (nested and (more nested)) parenthesis) till the end with (additional parens)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end