package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(((?:[^()]+|\((?1)\))+)\)`)
var str = `test (with (nested and (more nested)) parenthesis) till the end with (additional parens)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}