#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<input(?![^>]+type=)[^>]+>"
Local $sString = "<input name="a" type="button" />" & @CRLF & _
"<input name="b">" & @CRLF & _
"<input type="button" name="c">" & @CRLF & _
"<input type="button" name="d">" & @CRLF & _
"<input name="e">" & @CRLF & _
"<input name="f" type="button">" & @CRLF & _
"<input name="g">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")