re = /(?is)<input(?![^>]+type=)[^>]+>/
str = '<input name="a" type="button" />
<input name="b">
<input type="button" name="c">
<input type="button" name="d">
<input name="e">
<input name="f" type="button">
<input name="g">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end