using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)<input(?![^>]+type=)[^>]+>";
string input = @"<input name=""a"" type=""button"" />
<input name=""b"">
<input type=""button"" name=""c"">
<input type=""button"" name=""d"">
<input name=""e"">
<input name=""f"" type=""button"">
<input name=""g"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}