using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GET \/someportal\/rest\/product\/v1_0\/.*\/filename\/(?<FileName>\S+)";
string input = @"GET /someportal/rest/product/v1_0/clientidentifier/filename/fnm_123456789abcd.png HTTP/1.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}