const regex = /GET \/someportal\/rest\/product\/v1_0\/.*\/filename\/(?<FileName>\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('GET \\\/someportal\\\/rest\\\/product\\\/v1_0\\\/.*\\\/filename\\\/(?<FileName>\\S+)', 'gm')
const str = `GET /someportal/rest/product/v1_0/clientidentifier/filename/fnm_123456789abcd.png HTTP/1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}