re = /GET \/someportal\/rest\/product\/v1_0\/.*\/filename\/(?<FileName>\S+)/m
str = 'GET /someportal/rest/product/v1_0/clientidentifier/filename/fnm_123456789abcd.png HTTP/1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end