using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\((.*)\).*";
string substitution = @"+ FooBar(MT($1))";
string input = @"+ GF + MT('TeFreezNrGes') + GF + TZ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}