const regex = /.*\((.*)\).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\((.*)\\).*', '')
const str = `+ GF + MT('TeFreezNrGes') + GF + TZ`;
const subst = `+ FooBar(MT($1))`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);