re = /.*\((.*)\).*/
str = '+ GF + MT(\'TeFreezNrGes\') + GF + TZ'
subst = '+ FooBar(MT($1))'
result = str.sub(re, subst)
# Print the result of the substitution
puts result