package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.[a-zA-Z]?\d+)*$`)
var str = `123.123.123.132
123123213123
123.a123.b123.123
123.aa1.bb12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}