$re = '/^\d+(?:\.[a-zA-Z]?\d+)*$/m';
$str = '123.123.123.132
123123213123
123.a123.b123.123
123.aa1.bb12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);